Monthly Archives: April 2014

PSA: Heartbleed OpenSSL Vulnerability

Warning: OpenSSL vulnerability. I'll skip trying to re-explain everything and just link to: http://heartbleed.com/ The short version is that OpenSSL versions in the last ~2 years are vulnerable to having basically any confidential information stolen. Any exploited servers are vulnerable to having previously sniffed traffic decrypted, even after patching out the vulnerability. It is recommended…
Read more